A táblázatkezelõ programok

Induljunk ki a költségvetési számítások problémájából: egy számítás végeredménye egy másik számítás kiindulási adata. Az egymásra épülõ lánc hosszának növekedésével egyre több idõt vesz igénybe a számítás hagyományos módon, kézzel, zsebszámológéppel, történõ elvégzése, és ha utólag bármelyik elem megváltozik, lehet az egészet kezdeni elölrõl. Az ilyen feladatok megoldásához fejlesztették ki a táblázatkezelõ programot (VisiCalc). Jelenleg a kereskedelemben többféle táblázatkezelõ kapható. A legelterjedtebbek Corel Quattro, Lotus 123, Microsoft Excel. A ma kapható táblázatkezelõk mindegyike úgynevezett integrált programcsomag, vagyis a hagyományos táblázatkezelõi feladatok mellett alkalmasak bizonyos elemi adatbáziskezelõi feladatok megoldására, továbbá készíthetõ bennük diagramm.

2. ábra Az Excel 97 felülete
A táblázat legkisebb eleme a cella. A cella tartalmazhat szöveget, számot, képletet. Ha beírunk valamit egy cellába, akkor, ha az értelmezhetõ számként, akkor az Excel számként értelmezi, ellenkezõ esetben szövegként. Amennyiben a beírás mûveleti jellel vagy egyenlõségjellel kezdõdik, akkor képletként tárolódik el. A táblázaton belül minden egyes cellát meg lehet címezni az oszlop-sor koordináták alapján.
A következõ táblázatban az elõzõ ábra Minta táblázata látható, a cellákba beírt képletekkel.
A
B
C
3
Számok
Számok
a*b
4
1
11
=A4*B4
5
2
6
=A5*B5
6
3
3
=A6*B6
7
=SZUM(A4:A6)
=SZUM(B4:B6)
=SZUM(C4:C6)
A C oszlop, valamint a 7. sor képleteket tartalmaz. A képlethivatkozás lehet relatív (A oszlop 6. sor az A6), vagy abszolút ($A$6). A kettõ közötti különbséget a következõ egyszerû példával lehet bemutatni: a C4 cella tartalmát átmásoltam a C5 és C6 cellákba (kijelöltem a cellát, rákattintottam a szerkesztés menüben a Másolás almenüre, majd kijelöltem a célterületet, és a szerkesztés menü beillesztés parancsára kattintottam), A C4 cellában az =A4*B4 kifejezés szerepelt. Az Excel megjegyezte, hogy az A4 hivatkozott cella az átmásolt cellától 2, a B4 pedig 1 oszloppal balra, ugyanabban a sorban voltak. A célterület (C5) a C4-tõl egy sorral lentebb van, tehát a másolásnál csak a sor változott, az oszlop nem (oszlopváltozásra példa az A7 másolása a B7-C7 re). Az Excel a másolt képletben az oszlophivatkozást az oszlopváltozással, a sorhivatkozást a sorváltozással automatikusan korrigálja, ezért a C5 cellába az =A5*B5 képlet, a C6-ba =A5*B5 kerül. Abszolút hivatkozás esetén ez a korrekció elmarad, vagyis a képlet változatlan marad a cellában.
 
Elõzõ fejezet
Tartalomjegyzék
Következõ fejezet